3. Installation instructions

Be sure you have a recent version of Perl installed. At least List::Util is missing from versions earlier than 5.8. You can also just fetch this additional package from CPAN if you cannot upgrade. If you notice that another package is missing from your installation, please report it, so it can be listed here.

Other required perl modules:

Installation is like many other perl packages:

Example 1. Sample install session

$ perl Makefile.PL prefix=/usr/local
$ make
$ su
# make install

Be sure that the directory in which the library modules got installed is in your perl library path. Eg, if graph-includes --version does not give the expected result, try setting the PERL5LIB environment variable to (in the above example) /usr/local/share/perl/5.8.4/.

New versions can be found at https://alioth.debian.org/projects/deps/.

A darcs repository is available at http://deps.alioth.debian.org/darcs/deps/.

To be able to format the produced graphs, you will need one of graphviz and tulip